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1 INTRODUCTION

1.1 About MULTI POINT EDITOR
The MULTI POINT EDITOR (MPE) is a Windows based utility, which allows the user to open,
view, edit and save field correction files (*.fc3 or *.gcd) and power correction files (*.pc3) in
order to adapt them to the individual opto-mechanical situation of each laser system.

The functionality of the MULTI POINT EDITOR can also be used programmatically at API level,
but this would require the installation of the RAYGUIDE SDK, as the MULTI POINT EDITOR is
also an integral part of the RAYGUIDE Laser Process Software.

The goal of the MPE is mainly to edit the correction data of the axes of a deflection unit,
responsible for the XY position of the laser beam as well as the Z-axis of a prefocusing unit or
FOCUSSHIFTER to control the focus position. Other possible axes that are controlled by a *.fc3
correction file, such as SensorZ of an RAYSPECTOR, ZoomZ of an AM-MODULE and Aux-axis of
a RAYDIME METER are not calibrated by the MPE.

1.2 Compatibility
The MULTI POINT EDITOR software tool is compatible with the RAYLASE SP-ICE-3 scan
controller.

Please note that the software can be used without the connected scan controller if only
correction values are applied to a correction file.

1.3 Features
■ Calibration of the xy correction values of RAYLASE *.fc3 or *.gcd correction files

■ Calibration of the Z-correction values for the third optical axis (if available)

■ Creation of a correction table for field position dependent power correction

■ Direct marking of the calibration pattern (in connection with the use of a SP-ICE-3 control
card)

■ Definition of a sub field (if only a subarea of the scan field is usable)

■ Selection of different calibration patterns

■ Direct input of scaling, rotation, offset and trapezoidal deviations

■ Import function of measured values

■ Various visualization options of the calibration data for validation of the measured values

■ Creation of correction files that map the surface of a three-dimensional body

■ Calculation of maximum process speed values



1 INTRODUCTION

© 2025 RAYLASE GmbH 7MN_MULTI POINT EDITOR [V2.1]

1.4 Scope of delivery
A typical bundle delivered to the customer includes the following items:

■ MULTI POINT EDITOR software installation file to install all necessary program and library
files required for the MULTI POINT EDITOR.

■ MULTI POINT EDITOR user manual as PDF file.

■ License agreement as PDF file.

1.5 Laser Safety
The user is responsible for safe operation and for protecting the area around the device from
hazards caused by laser radiation. OEM customers must ensure compliance with all local and
national regulations.

WARNING
Avoid unsafe laser operation

Always switch on the PC before switching on the laser system. This prevents the laser from
behaving in an uncontrolled and unforeseen manner when the PC is switched on. Check
your application carefully before using the laser system. Damaged software can block the
entire system and lead to uncontrolled operation of the laser or deflection unit.

Safety instructions for these components can be found in the manuals for the laser system
and deflection unit.
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1.6 About this Manual
This manual describes the entire functionality and performance features of the MULTI POINT
EDITOR software when used with the graphical user interface (GUI).

Conventions
■ Emphasized phrases are printed in bold.

■ Important notes and remarks are introduced with NOTE:, RULE:, etc.

■ Folder and file names are printed in italics.

■ The names of windows, dialogs and tabs are given as normal text: On the Settings tab.

■ Menu options are shown in bold and italics: Select File > Save as....
■ The names of dialog options (function buttons, checkboxes) are specified in italics: Select

Fixed, if you ...

■ Buttons are bold and in italics and shown in brackets: Click on [Apply].

■ Buttons labeled with graphic icons are described in words.

Example:  is a [Zoom] button.

■ References to other pages in the manual are indicated by italics: See page 22, Setup.

■ Links to web addresses are underlined: Visit RAYLASE.

1.7 Legal Information

Copyright

RAYLASE reserves the right to make changes to the product described in this manual and to
the contents of this manual at any time without notice.

All rights reserved.

Duplication of this manual or extracts from it – in particular by photocopying, scanning or
photographing – and any other form of reproduction is only permitted with the prior written
consent of RAYLASE.

License agreement

The text of the license agreement is delivered as a PDF file together with the software.

Warranty

The rights of the customer in case of material or legal defects of the product are listed in the
General Terms and Conditions of RAYLASE. These can be viewed at: https://www.raylase.de/
en/terms-and-conditions.html.

No implied warranty or guarantee is given as to fitness for a particular purpose. RAYLASE is
not responsible for any damage caused by using the application. Custom assemblies or other
assemblies manufactured by RAYLASE may be subject to different warranty terms. Further
information can be found in the respective manuals.

https://www.raylase.de/de
https://www.raylase.de/en/terms-and-conditions.html
https://www.raylase.de/en/terms-and-conditions.html
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1.8 Addresses

Manufacturer

RAYLASE GmbH

Argelsrieder Feld 2+4

D-82234 Wessling

www.raylase.de

Phone: +49 8153 9999 699

Fax: +49 8153 9999 296

E-mail: info@raylase.de

Customer Service

RAYLASE customer service will be happy to help you at any time if you have any problems
with the software or this manual.

Availability: Monday to Friday, 9:00 a.m. to 5:00 p.m.

UTC+1 (April to October: UTC+2)

Phone: +49 8153 9999 297

E-mail: support@raylase.de
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2 INSTALLATION AND LICENSE

2.1 Installation process
NOTE: Once using the RAYGUIDE application software, the MULTI POINT EDITOR feature is
embedded per default and does not need to be installed additionally.

For installation of all RAYLASE software products (therefore also the MULTI POINT EDITOR
application), RAYLASE provides the so-called RAYBOARD PRODUCT INSTALLER (RBPI) free of
charge as a central tool on its website.

First install (RAYBOARD PRODUCT INSTALLER)

https://www.raylase.de/en/products/software/rayboard/product-installer.html

Here in the “Select the targeted software configuration” menu item, select MULTI POINT
EDITOR with the most current version.

Fig. 2.1: S-AAA

You can use the direct link to the change log to get an overview of the latest changes to the
previous version. The RBPI will then download the MULTI POINT EDITOR installation file and
the installation options will be displayed.

Accept the license agreement.

After successful installation, you will receive the following information in the RAYBOARD
PRODUCT INSTALLER.

Fig. 2.2: S-AAB

https://www.raylase.de/en/products/software/rayboard/product-installer.html
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A symbol for starting the MULTI POINT EDITOR application directly on the desktop of the
computer is created:

Fig. 2.3: MPE-AAC

Starting software

For instance, use the MULTI POINT EDITOR desktop icon ton start the software.

2.2 License
The MULTI POINT EDITOR is basically a freeware tool. Only the use of the creation of
3D surface correction files requires a MPE Professional license.

The license is distributed in two ways:

■ A hardware dongle (hardware license key), to be inserted into a USB port of the computer
running the software. This variant allows you to install the software on more than one
computer and use the same dongle on each of them in turn. When the software is
installed or started with the dongle attached, the license is found and activated
automatically.

■ A software key (activation license key), which is valid only for a specific computer. To use a
software key, a "fingerprint" of the designated computer has to be generated. In the
menu, select RAYGUIDE Help > License > Generate license request…, and send the
generated file to RAYLASE (license@raylase.de). RAYLASE will return an activation file
which can be imported by selecting Help > License > Activate license.

NOTE: The MPE Professional license can also be added to an existing RAYGUIDE license via
push-update, also using the menu option Help > License > Activate license.

As soon the MPE recognizes the Professional license, it will be mentioned in the top bar.
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3 INTRODUCTION TO THE USER
INTERFACE
By default, the tab Marking is shown after the start of the application.

1 2 3

4

Fig. 3.1: MPE-AAD

1 Menu 2 Main tabs

3 Loaded file name and possible license 4 Info bar

The File menu refers to common job file tasks. It also provides the option to generate or
power correction files (see page 63, Position dependent power correction file).

The Edit menu provides options for changing field size and defining sub fields, changing the
resolution of the lookup tables and header information. There is also an option to convert a
3D correction file to a 2D correction file hosted here.



3 INTRODUCTION TO THE USER INTERFACE

© 2025 RAYLASE GmbH 13MN_MULTI POINT EDITOR [V2.1]

The Measurement menu provides the option to define the measurement table and to
transfer measurements either by loading them in the same table format as defined (see page
41, Loading measurement values from a file) or by importing a list of freely defined
coordinates (see page 50, Importing a list of measurement values).

In the Correction menu, global field corrections such as scale, offset, rotation, and trapezoid
can be applied. An analysis option provides some statistical information as well as options to
copy the correction values from the lookup table in either table or list format. The options for
creating 3D-Surface correction files are also available from this menu.

The Help menu provides shortcuts to this manual, log files, and version information.

Applicable keyboard shortcuts are shown after most menu items.



4 GENERAL PREPARATIONS

© 2025 RAYLASE GmbH 14MN_MULTI POINT EDITOR [V2.1]

4 GENERAL PREPARATIONS

4.1 Loading a correction file
Go to File > Open and browse for the desired correction file (RAYGUIDE usually stores its
correction files usually under C:\ProgramData\RAYLASE\Correction Files).

Alternative: you can simply drag & drop the file from the folder into the MPE application
window, or simply double-click on the file, and the file will start the MPE application if it is
available.

For *.gcd files (used on SP-ICE-1 PCI/e PRO control card):

■ If in the same directory the description file with a *.txt extension exists, it will also be
loaded as well and important parameters such as the field size will be extracted.

■ If no such *.txt file exists, you will need to set the field size manually.

When the MPE is started from the RAYGUIDE application, the associated correction file is
automatically selected and loaded.

4.2 Type of field calibration
The MPE offers two basic ways to calibrate a scan field:

1. If the scan field requires global adjustments such as scaling, offset, rotation or trapezoidal
distortion correction, these can be done directly. This could also mean a global focus
adjustment that defines a bias / offset for the (all available) Z-axes.

2. If you need a very precisely calibrated scan field and also want to correct inhomogeneous
distortions, then a true multi-point correction, which includes global adjustments, is the
way to go.

Therefore, you will usually choose either option 1 (see page 15, Global field corrections) or
option 2 (see page 18, System dependent considerations and page 22, Multipoint
calibration).
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5 GLOBAL FIELD CORRECTIONS
NOTE: In the case of a 3D correction file, any of the following global corrections will be
applied to all Z‑layers.

5.1 Apply scale
To scale the marking result globally, you can apply scaling factors for X and Y to the entire
field correction table.

It is recommended to mark a square of ¾ field size, to measure the dimensional error.

Go to the menu Correction > Apply scale to open the following dialog:

Fig. 5.1: MPE-AAE

Since the scaling is applied to the field correction table, only small scale errors should be
applied.

NOTE: Larger scale deviations may result from incorrect working distance adjustments. They
should not necessarily be corrected by mechanical adjustment.
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5.2 Apply offset
To shift the X- / Y-position of the field center, you can apply an offset to the entire field
correction table.

It is recommended to mark a large center cross to evaluate the offset.

In case of a prefocusing deflection unit (AXIALSCAN, AS FIBER, FOCUSSHIFTER) an offset can
also be applied to the Z dimension to shift the focus globally.

To access the Z offset field, the units must be selected as either 16 bit, 20 bit or percentage.

Go to the menu Correction > Apply offset to open the following dialog:

Fig. 5.2: MPE-AAF

Unit of measure controls whether the offset is applied in field coordinates (mm) or control
value (20 bit).

5.3 Apply rotation
To rotate the marking result globally, one can apply a rotation to the entire field correction
table.

It is recommended that only small (single digit) rotations be compensated.

It is recommended to mark a large center cross, to evaluate the rotation.

Go to the menu Correction > Apply rotation to open the following dialog:

Fig. 5.3: MPE-AAG
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5.4 Apply trapezoid
You can use this option to correct a global trapezoidal distortion of the marking result.

It is recommended to mark a square to measure the trapezoidal distortion.

Go to the menu Correction > Apply trapezoid to open the following dialog:

Fig. 5.4: MPE-AAH

After selecting the axis to be compensated, the measured sizes can be set.

NOTE: A trapezoidal distortion can only be corrected along one field axis.

For the X-axis, measure and enter the top and the bottom sides, and for the Y-axis, measure
and enter the left and the right side dimensions.

5.5 Apply barrel distortion
Use this option to correct a global barrel distortion of the marking result. It is recommended
to mark a square to measure the barrel distortion.

The distortion is usually along a coordinate axis, either the X-axis (width) or the Y-axis
(height).

Go to the menu Correction > Apply barrel distortion to open the following dialog:

Fig. 5.5: MPE-ABT
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6 SYSTEM DEPENDENT
CONSIDERATIONS

6.1 Deflection units with f-theta lenses
For all deflection units with f-theta lenses (2-axis deflection unit or FOCUSSHIFTER) only the
scan field needs to be calibrated.

6.2 Prefocusing units (AXIALSCAN, AS FIBER)
For prefocusing deflection units, it is recommended that you start with the focus calibration
and then continue with the scan field calibration.

6.3 Correction files that provide a 3D volume
If the selected correction file provides a 3D volume, both the focus calibration and the scan
field calibration can be performed at multiple focus layers. It is recommended to calibrate at
least the top and bottom layers, so that all layers in between are interpolated.

Select Multi Layer as 3D Mode, see page 23, Definition of calibration job layout, using
predefined pattern styles.

6.4 Correction files with spot magnification
Correction files for the RAYLASE AM-MODULE contain multiple data layers with respect to
spot magnification. Similar to a 3D volume correction file, it is recommended to perform the
scan field calibration at least at the min and max spot magnification layers, so that all layers
in between will be interpolated.

Select Multi Magnification as Magnification Mode, see page 23, Definition of calibration job
layout, using predefined pattern styles.

NOTE: It is not recommended to calibrate the focus, as this would only affect the Z axis
correction data, but during the process, both axes (Z and ZoomZ) perform a correlated
movement.
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6.5 Optional field range limitation for calibration
(sub field)
Customers who do not want to or are unable to use the entire scan field can define a smaller
section – hereafter referred to as “sub field”.

This option can be used for correction files that represent a flat field or a 3D volume.
Calibration data for additional axes such as ZoomZ, SensorZ, Aux-axis will also be cropped by
a sub field.

NOTE: Only the measurement area is reduced. Correction data outside the sub field is
retained.

Go to Edit > Change field to open below dialog:

Fig. 6.1: MPE-AAI
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Element Explanation

Define field parameter

Field size [mm] Displays the field size per X- and Y-dimension as defined by the loaded
correction file.

Define sub field Select the check box if you want to define a sub field.

Sub field

Sub field size [mm] Enter the X- and Y-dimensions of the required sub field.

Sub field offset [mm] Enter the X- and Y-offsets if the sub field is not centered to scan field.

Circular sub field Select whether the sub field should be circular instead of rectangular.

NOTE: The size of the circular sub field defined in this way can exceed the size
of the original field. Combined with the offset, this can result in a circular
sector. This can be useful for a circular field covered by several deflection units.

Table. 6.1: MPE-001

Example 1: Circular sub field

Table. 6.2: MPE-025

Because the measurement table is always rectangular, not all values need to be filled in. All
cells corresponding to grid points outside the circle are crossed out and extrapolated.
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Example2: Circular sub field

Table. 6.3: MPE-026

The measurement table shows only those cells of the sub field that are inside the original
field. Since much of the circle is outside the original field, the table is reduced from 8 x 8 to
7 x 7 points.

NOTES:
■ A sub field affects both the marking grid, which is truncated accordingly, and the

measurement points which need to be entered.

■ Correction points outside the sub field will also be updated, but because the correction
values are extrapolated, the accuracy may suffer.

■ Correction file data sent to a control card will not be truncated by a sub field definition.
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7 MULTIPOINT CALIBRATION

7.1 Marking of the calibration pattern

7.1.1 Preparing the marking pattern “Job”
Using the MPE in combination with RAYLASE SP-ICE-3 control card, you can define and
execute a calibration pattern and then measure the grid points afterwards. This requires a
connection to an SP-ICE-3 control card. This task is managed in the Marking tab.

Fig. 7.1: MPE-AAN

The following sections explain all the options on the Marking tab.

7.1.1.1 Connect to a control card

Card connection

Selected card Displays the connected control card with its serial number and IP address.

After a detection, all available control cards are listed, and the desired one can
be selected.

Discover Click to start discovering of all available control cards on the network.

[Connect] /
[Disconnect]

Press [Connect] to connect to the selected control card and send the active
correction file to the card.

Press [Disconnect] to release the current connection, e.g. for rediscovering or
to connect to another card.

Deflection unit index If the control card uses the dual scan head mode to control two deflection units
in master-slave mode, the index of the head to be calibrated can be selected.

NOTE: If index 1 is selected, the same correction file will be stored on the card
for both heads. Once both heads have completed their multipoint calibration,
the configuration must be set up again.
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Card connection

NOTES:

If another correction file is loaded after the control card is connected, the file is automatically uploaded to
the card.

In case the MPE is started from the RAYGUIDE application, the connection is already established and the
correction file as assigned in RAYGUIDE is selected.

Once the MPE is connected to the card, it reads the actual field transformation values from the scan
controller.

This transformation may include gain, offset and rotation correction previously set by another application
(e.g. RAYGUIDE). It is displayed in a pop-up dialog:

Select [Yes] or [No] if you want to embed or not to embed the transformation in the correction file.

IMPORTANT NOTES:

In any case, the transformation is deleted from the control card, since it would otherwise affect
the execution of the pattern. In addition, the process transformation is also deleted.
If you have decided not to embed the values after completing the multipoint correction task, be
sure to set the values again.

NOTE: If MPE is started from RAYGUIDE and you decide to embed the transformation, the field
transformation values for will also be reset in the RAYGUIDE deflection unit configuration.

Table. 7.1: MPE-022

7.1.1.2 Definition of calibration job layout, using predefined
pattern styles
For prefocusing systems, it is recommended to start with the focus calibration, see pattern
option “Focus calibration”.

Click the [Refresh] icon to refresh the marking pattern display.
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Calibration Pattern

Pattern Scan field multipoint calibration

■ XY Grid

The XY Grid is the best choice for manual measurements.

■ XY Drill

Compared to the XY Grid, each grid point is represented by a drill point.

■ XY Circle

Compared to the XY Grid, each grid point is represented by a small circle.

NOTE: It is not possible to mark complete circles at the edge of the field. To
overcome this limitation, you can define a sub field (see page 19, Optional
field range limitation for calibration (sub field)) that is one circle diameter
smaller than the field.

■ XY Cross

Compared to the XY Grid, each grid point is represented by a cross.

NOTE: It is not possible to mark complete crosses at the edge of the field. To
overcome this cut-off, you can define a sub field (see page 19, Optional field
range limitation for calibration (sub field)) that is one cross size smaller than
the field.

Focus calibration

(only for correction files for prefocusing deflection units)

■ Z Lines

Each grid position is represented by a line array, where the focus position is
incremented per line to identify the best-in-focus line.

Grid Points Number of grid points for complete X- and Y-axis range.

The fields for X and Y are interlocked. Click the lock button to unlock the two
fields.

Recommendation: The measurement grid should have its grid points on the
grid points of the correction file.

This can be achieved with the following number of columns / rows (only if no
sub field is set):

3, 5, 9, 17, 33, 65, 129, 257.

Application Note: Typically, a grid of 9 x 9 points provides sufficient position
accuracy.

Pulses 1 Enter the number of pulses for drill points.

Highlight center 1 Check to add four more drill points around the center of the grid.

Radius [mm] 2 Enter the radius of the pattern circles.

1 Available only when the pattern XY Drill is selected.

2 Available only when the pattern XY Circle is selected.
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Calibration Pattern

Surrounding box 3 Adds a square around the crosses.

Surrounding box scale 3 Scales the squares relative to the size of the crosses.

Lines per point 4 Enter an odd number of lines to be marked at each grid point position.

The lines (vertical by default) are arranged symmetrically, with every 5th line
drawn slightly longer.

Line spacing [mm] 4 Enter the line spacing between the parallel Z-lines.

Delta Z [mm] 4 Select whether the Delta Z value applies to the Z-lens or to the focus.

NOTES:
■ When Z-lens is selected, the value refers to the range of movement of the

axis. A delta value of about 100 µm can cause a noticeable change in the
focus position.

■ When focus is selected, the value refers to the field domain. The MPE
internally converts the value to a lens offset using a special algorithm to
control the Z-axis.

Line length scale 4 Enter the value by which each line is shifted relatively in Z-position, while the
center line is marked at the nominal Z-position.

The length of the lines can be reduced to avoid possible overlapping of line-
groups. The value is 0,66.

Horizontal 4 Switches the orientation of the lines from vertical to horizontal lines.

Label Axis Select this check box to additionally mark labels to identify the X‑ and Y-axes.

Small Select to force the axis label to fit the label size to the free space between the
grid marking instead of overlapping, and to use a single stroke font instead of
true type font

Label measurement
points

Select to additionally mark the X/Y index at each grid position.

NOTE: In the same cases, two labels may overlap.

Reduced Select to limit the number of grid labels to 9 x 9 to avoid overcrowding the
pattern being marked.

3 Available only when the pattern XY Cross is selected.

4 Available only when the pattern Z Lines is selected.
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Calibration Pattern

Truncate to sub field NOTE:

If a sub field is used, the grid points of the markup are adjusted to fit the
rectangular bounding box of the sub field.

If this option is checked, the marking pattern will also be cut off at the sub field
edge (see page 19, Optional field range limitation for calibration (sub field)).
Useful mainly for circular sub fields:
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Calibration Pattern

3D Mode 5 /

Magnification Mode 6

Select, if the pattern is marked

■ just in a SINGLE Z position / SINGLE magnification level

NOTE: If only a single Z / magnification position is calibrated, the correction
values for all other Z layers / magnification-levels will be extrapolated.

■ or in MULTIPLE Z positions / MULTIPLE magnification levels.

NOTE: When calibrating multiple Z positions / magnification levels, the MPE
will interpolate the correction values for layers in between.

Z position [mm] 7 /

Magnification Level 7

■ SINGLE layer:

Enter the Z position / magnification level relative to the working distance for
the pattern to be marked.

■ MULTIPLE layer:

A list of all layers / levels, as defined in the correction file, will appear.

Simply check from the offered indexes which focus layer / magnification level
should be used to perform the calibration marking.

If the predefined layers cannot be used to place a material, additional custom
Z‑layers can be added. Click [Add custom] to add an additional layer and
define its Z position.

NOTE: When the pattern has been marked in the first selected Z position /
magnification level, a pop-up dialog appears, waiting for your confirmation to
continue

■ to mark the pattern again at the next Z position /

■ with the next magnification factor

until all selected Z positions / magnification factors have been processed.

Example: 3D CF - Single Layer selection

5 Available only when a 3D correction file is loaded.

6 Available only when a correction file is loaded, that supports an additional zoom lens.

7 Depending on the mode selection (3D Mode, Magnification Mode)
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Calibration Pattern

Example: 3D CF - Multi Layer selection with custom layers

(FOCUSSHIFTER correction file e.g. does not have a Z-Layer for Z = 0 by default)

Table. 7.2: MPE-023
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Example pattern layouts with 9 x 9 grid points

1 2

3 4

Fig. 7.2: MPE-AAO

1 Grid style (with labels) 2 Drill style (with highlighted center)

3 Circle style 4 Cross style
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Z-lines (for focus calibration of prefocusing deflection units)

1 2

Fig. 7.3: MPE-AAP

1 Z-lines (none-Z-lens-offset CF) 2 Z-lines (predefined Z-lens-offset CF)

■ Correction file without Z-lens offset:

The center positioned line-arrays miss some lines, because the focus positions of those lines
would be beyond what the Z-lens can reach.

■ Correction file with predefined Z-lens offset:

Usually every focus position of the pattern can be reached. Therefore, all grid positions
show their defined number of lines.
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7.1.1.3 Defining the process parameters, used to mark the pattern

Pen Select a pen to define the process parameters for marking the pattern

This option is only available when MPE is started from the RAYGUIDE
application.

Table. 7.3: MPE-002

Scanner

Click the [Download] button to download the current process parameters for the deflection unit and laser

from the connected control card: 

Mark Speed [m/s] Speed of the laser spot on the material

Mark delay [µs] This value is applied after a mark vector, often before a subsequent jump vector.
The value refers to the dynamics of the deflection unit.

Poly Delay [µs] The value refers to the dynamics of the deflection unit. The delay is applied at
the transition point between two consecutive mark vectors.

Jump Speed [m/s] Relative speed, when the deflection unit changes position without laser
emission.

Jump Delay [µs] The delay is applied after a position jump, often before a subsequent mark
vector. The value refers to the dynamics of the deflection unit.

Table. 7.4: MPE-003

Laser

Power [%] Power value to set emitted laser power. The percentage always refers to a
100 % scale.

LM Frequency [kHz] Value to define the pulse rate of the laser modulation (LM) signal.

LM Width [µs] Value to define the pulse width of the laser modulation (LM) signal.

Laser-On Delay [µs] Values to synchronize the laser activity with the mirror position at the start and
end of a laser path. It can also be set with a negative sign.

Laser-Off Delay [µs]

Table. 7.5: MPE-004

IMPORTANT NOTES when the MPE is not started from the RAYGUIDE application:

The MPE only allows the most important process parameters to be set. All other process
parameters must be set using the control card config tool.

All system configuration settings, such as the laser configuration, must also to be set using the
control card config tool.
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7.2 Executing the marking pattern “job”
Main controls for execution:

Fig. 7.4: MPE-AAQ

To execute the pattern with the laser, the [Arm]-Button must be turned ON (red).

Otherwise, the control card won´t request laser emission.

NOTE: When the laser is disarmed, the MPE commands the pointer signal to be on.

To start the execution, press the [Play] button.

In each case, a pop-up dialog will first display the Z position for the marking.

Example:

Fig. 7.5: MPE-AAR

NOTE for 3D calibration: If the marking is to be performed in a multi Z level selection, the
popup will reappear for each selected Z position until all positions have been processed. In
this way, the popup pauses the execution loop to give you time to place the marker material
at the new focus position.

Only after confirming this message, the execution will start.

The status bar indicates whether the laser job running:

Fig. 7.6: MPE-AAS

Use the [Abort] button to stop the execution at any time.
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7.3 Entering the measurements

7.3.1 Creating a new measurement table
The best practice is to use the [New table] button right below the execution buttons:

Fig. 7.7: MPE-AAT

This way, the table will already appear with the correct number of cells according to the
previously selected grid points, and all cells that are not in the optionally defined sub field
will be crossed out.

Alternatively, you can use the menu item Measurement > New table. This can be used
when the grid has been marked without using the MPE.

The dialog that appears requires the following information (depending on the correction
file):

Fig. 7.8: MPE-AAU
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Define table

Grid Size 
(columns x rows)

It is recommended to use a grid, whose grid points correspond to the grid
points of the correction file.

This can be achieved with the following number of columns / rows: 
3, 5, 9, 17, 33, 65, 129, 257.

NOTE: The grid size should be the same as the number of grid points which
were marked.

APPLICATION NOTE: A 9 x 9 grid is usually sufficient for position accuracy.

Use the [Lock] button to allow different values for columns and rows if
necessary.

Number of layers 8 In the case of a 3D correction file, you can define the number of Z layers in
which you have marked and measured pattern to perform the XY field
calibration.

Layer selection 8 Use the expander to view the layer selection:

Shows a preselection of the layers (count and Z value) evenly distributed
according to the defined number of layers in relation to the available layers of
the loaded correction file.

If desired, use the drop-down selection to switch to another available layer.

Number of magnification
levels 9

In the case of a correction file that supports a zoom lens (e.g. for RAYLASE
AM-MODULE), you can specify the number of marked magnification levels
and measured pattern to perform the XY field calibration.

Magnification selection 9 Use the expander to view the magnification selection:

Shows a preselection of the levels (count and magnification factor) evenly
distributed according to the defined number of levels in relation to the
available levels of the loaded correction file.

If desired, use the drop-down selection to change to another available factor

8 Only accessible if the loaded correction file provides a 3D volume.

9 Only accessible if the loaded correction file supports the ZoomZ-axis.
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Define table

Calculation Mode Depending on the correction task, the following calculation modes are
available:

■ Error Interpolation

Default mode for any standard XY field correction

■ Absolute interpolation

If you want to set the field correction directly. For more details refer to
page 40, Enter measurements for focus calibration using absolute values.

■ Z-Line

Default mode for Z-axis (focus) calibration

The Delta Z [mm] can be either related either to

– the lens or

– the focus.

Table. 7.6: MPE-005

When the settings are complete, press [OK] and the new table appears on the
Measurements tab.

7.3.2 Tab “Measurements“

7.3.2.1 Enter measurements for scan field calibration
The Measurements table by default is divided into two tabs:

■ one for the X-values and

■ one for the Y-values of the measured grid points.

The displayed values, as well as the values in the column / row header, show the expected X-
and Y-coordinate value of the grid points in [mm].

In the case of a sub field that's offset relative to the actual scan field, the expected grid
coordinates in the table shown refer to the center of the sub field. The grid points themselves
are always evenly spread over the sub field size along the two coordinate axes.
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Example: Original Measurements table with sub field definition

Fig. 7.9: MPE-AAV

Example: Original Measurements table with 4 selected Z-layers

Fig. 7.10: MPE-AAW

The slider position connects the measurement table e.g. with the focus layer / magnification
layer of the correction file. Now move the slider to each available layer and enter the
measured values in the X- and Y-table.
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TIP about useless cells: If the scan field contains areas that could not be marked, and
therefore no measurement data is available for these grid points, you can select the
corresponding cells in the table (multiple selection possible), use the context menu Toggle
ignored cells.

Fig. 7.11: MPE-AAX

The selected cells are then crossed out, just like cells outside a sub field, and are ignored in
the error calculation.

NOTE: Note that if too many cells are missing, the calibration result will suffer. This is
especially the case if cells are missing at the edge of the sub field, requiring extrapolation..

Below the table, the MPE displays information about the average correction in [µm] and the
maximum correction in [µm].

Once all measurement data has been entered, you can use the [Show graph] option to
navigate to the Graph tab to review the resulting impact of the measurement on the
correction file. For more details on the graph, refer to chapter page 51, Graphical
visualization of correction file data.

Press [Apply] to calculate the new field correction.

TIP: If you want to save the entered measurement data for further use, e.g. possible re‑import
or archiving, use the Measurement > Save table menu.
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7.3.2.2 Enter measurements for focus calibration
The Measurements tab only provides one table for the Z-axis.

Different from the field calibration, where you enter the measured grid point coordinate, you
have to enter the order number of the "best in focus" line for each grid position. The center
line has an order number of zero.

TIP: If the best focus position is not clearly on one line, but between two marked lines, you
can also enter a floating point number, e.g. 1,5.

Fig. 7.12: MPE-AAY

Move the slider to each layer position and enter the values determined in the tables.

The sign of the order number of the other lines could be noted as follows:

■ Left: Vertical line pattern
■ Right: Horizontal line pattern
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Fig. 7.13: MPE-AAZ

If the focus calibration is to be performed for several focus layers, a layer slider to the left of
the table allows you to select the corresponding layer. The layer slider represents your
previous done layer selection.

Fig. 7.14: MPE-ABB
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7.3.2.3 Enter measurements for focus calibration using absolute
values
As a special approach, you may be able to provide the absolute position of the Z‑lens relative
to its travel range.

In this case, when defining the measurement table, the calculation mode must be set to
“absolute interpolation” and the Z-axis must be selected.

Currently, this mode is only supported for Z-axis.

Fig. 7.15: MPE-ABC
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The values are now displayed in millimeters and can be edited directly.

When the changes are applied, the values are interpolated to fit the size of the correction
table and replace the original correction values of the selected axis.

Fig. 7.16: MPE-ABD

7.3.3 Loading measurement values from a file
Loading the measurement from a file can support two main use cases:

■ You have saved the previously entered measurements and want to reload them.

■ You use a measuring device that automatically measures the marked position and
generates a table of values.

The data is entered into a text based file, the application related file name is *.mtf.

The “type= Error” corresponds to the field correction. According to the “Error Interpolation”
calculation method these values define the actual marked position.

The “Type = Offset” corresponds to the “Z-Line” calculation mode used when performing the
3rd-axis multi point calibration (see page 38, Enter measurements for focus calibration).

If no type is specified, it defaults to Error.

NOTE: The specified field size (in [µm]) must match the field size of the supplied correction
file! Otherwise, you will get an exception.
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7.3.3.1 Loading the complete measurement data
Go to Measurement > Load table in order to select the measurement file to load.

This text file must be in the following format:

■ Lines to be ignored must begin with ‘#’ or be blank.

■ Each row lists one data point.

■ All other rows are treated as valid data.

■ The coordinates in each valid line must be separated by tab, space, or semicolon.

■ The coordinates must follow the US-English numbering style, i.e. ‘.’ (dot) as the decimal
point.

■ All units (except for row, column etc.) are in microns.

If the header line contains “layer”, the first column is interpreted as layer.

If it contains magnification and layer, the first column is magnification, the second is layer.

NOTE: In practice, either the magnification or the layers will have multiple entries, never
both.

The header row contains the index of the layer / magnification while the corresponding
column contains the count, starting from zero.

If a sub field is defined (=SubFieldSize), has an offset (=SubFieldOffset), and if the sub
field will be circular (=IsCircularField), this information is also mentioned in the header.

NOTE: You may need to save a sample of your specific measurement table to see the format
required.

Next are a few examples:
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Example 1:

Prefocusing deflection unit, flat field (XY calibration, single layer)
# Multipoint FieldCorrection File

# The data contained herein describes the actual positions where the laser fired

# All units (except for row and column etc) are in microns

# Each line lists one data point consisting of

# [Magnification/Layer/]Row/Column: the position where the data point is expected
expressed as [magnification/layer/]row/column

# ActualX/Y/Z: the position where the laser truly fired

# Empty lines and lines that begin with '#' are ignored

# The fields can be separated by <space>, <tab> or <semicolon>

# The floating point values must use '.' as the decimal point

; Type: Error

; FieldSize: 300000 300000

; Selected layers:

; Selected magnifications:

; Magnification [] Layer [] Row [] Column [] ActualX [um] ActualY [um] ActualZ [um]

0 0 0 0 -150000 -150000 0 0 0

0 0 0 1 -112500 -150000 0 0 0

0 0 0 2 -75000 -150000 0 0 0

0 0 0 3 -37500 -150000 0 0 0

0 0 0 4 0 -150000 0 0 0

0 0 0 5 37500 -150000 0 0 0

0 0 0 6 75000 -150000 0 0 0

0 0 0 7 112500 -150000 0 0 0

0 0 0 8 150000 -150000 0 0 0

0 0 0 0 -150000 -112500 0 0 0

0 0 1 1 -112500 -112500 0 0 0

0 0 1 2 -75000 -112500 0 0 0

0 0 1 3 -37500 -112500 0 0 0

0 0 1 4 0 -112500 0 0 0

0 0 1 5 37500 -112500 0 0 0

0 0 1 6 75000 -112500 0 0 0

0 0 1 7 112500 -112500 0 0 0

0 0 1 8 150000 -112500 0 0 0

0 0 2 0 -150000 -75000 0 0 0

0 0 2 1 -112500 -75000 0 0 0

0 0 2 2 -75000 -75000 0 0 0

Table. 7.7: MPE-007
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Example 2:

Prefocusing deflection unit, 3D volume (3 focus layers selected for XY calibration)
# Multipoint FieldCorrection File

# The data contained herein describes the actual positions where the laser fired

# All units (except for row and column etc) are in microns

# Each line lists one data point consisting of

# [Magnification/Layer/]Row/Column: the position where the data point is expected
expressed as [magnification/layer/]row/column

# ActualX/Y/Z: the position where the laser truly fired

# Empty lines and lines that begin with '#' are ignored

# The fields can be separated by <space>, <tab> or <semicolon>

# The floating point values must use '.' as the decimal point

; Type: Error

; FieldSize: 1000000 1000000

; SubFieldSize: 850000 850000

; SubFieldOffset: 0 0

; IsCircularField: False 10

10 Example continues on next page.
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; Selected layers: 0 8 16

; Selected magnifications:

; Magnification [] Layer [] Row [] Column [] ActualX [um] ActualY [um] ActualZ [um]

0 0 0 0 -425000 -425000 0 0 0

0 0 0 1 -318750 -425000 0 0 0

0 0 0 2 -212500 -425000 0 0 0

0 0 0 3 -106250 -425000 0 0 0

0 0 0 4 0 -425000 0 0 0

0 0 0 5 106250 -425000 0 0 0

…

0 1 0 0 -425000 -425000 0 0 0

0 1 0 1 -318750 -425000 0 0 0

0 1 0 2 -212500 -425000 0 0 0

0 1 0 3 -106250 -425000 0 0 0

0 1 0 4 0 -425000 0 0 0

0 1 0 5 106250 -425000 0 0 0

0 1 0 6 212500 -425000 0 0 0

0 1 0 7 318750 -425000 0 0 0

0 1 0 8 425000 -425000 0 0 0

…

0 2 0 0 -425000 -425000 0 0 0

0 2 0 1 -318750 -425000 0 0 0

0 2 0 2 -212500 -425000 0 0 0

0 2 0 3 -106250 -425000 0 0 0

0 2 0 4 0 -425000 0 0 0

0 2 0 5 106250 -425000 0 0 0

0 2 0 6 212500 -425000 0 0 0

0 2 0 7 318750 -425000 0 0 0

Table. 7.8: MPE-007
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Example 3:

AM-MODULE, flat field (3 magnifications selected for calibration)
# Multipoint FieldCorrection File

# The data contained herein describes the actual positions where the laser fired

# All units (except for row and column etc) are in microns

# Each line lists one data point consisting of

# [Magnification/Layer/]Row/Column: the position where the data point is expected
expressed as [magnification/layer/]row/column

# ActualX/Y/Z: the position where the laser truly fired

# Empty lines and lines that begin with '#' are ignored

# The fields can be separated by <space>, <tab> or <semicolon>

# The floating point values must use '.' as the decimal point 11

11 Example continues on next page.
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; Type: Error

; FieldSize: 500000 500000

; Selected layers:

; Selected magnifications: 0 4 8

; Magnification [] Layer [] Row [] Column [] ActualX [um] ActualY [um] ActualZ [um]

0 0 0 0 -250000 -250000 0 0 0

0 0 0 1 -187500 -250000 0 0 0

0 0 0 2 -125000 -250000 0 0 0

0 0 0 3 -62500 -250000 0 0 0

0 0 0 4 0 -250000 0 0 0

0 0 0 5 62500 -250000 0 0 0

0 0 0 6 125000 -250000 0 0 0

…

1 0 0 0 -250000 -250000 0 0 0

1 0 0 1 -187500 -250000 0 0 0

1 0 0 2 -125000 -250000 0 0 0

1 0 0 3 -62500 -250000 0 0 0

1 0 0 4 0 -250000 0 0 0

1 0 0 5 62500 -250000 0 0 0

1 0 0 6 125000 -250000 0 0 0

1 0 0 7 187500 -250000 0 0 0

1 0 0 8 250000 -250000 0 0 0

…

2 0 0 0 -250000 -250000 0 0 0

2 0 0 1 -187500 -250000 0 0 0

2 0 0 2 -125000 -250000 0 0 0

2 0 0 3 -62500 -250000 0 0 0

2 0 0 4 0 -250000 0 0 0

2 0 0 5 62500 -250000

2 0 0 6 125000 -250000 0 0 0

2 0 0 7 187500 -250000 0 0 0

2 0 0 8 250000 -250000 0 0 0

2 0 0 10 -250000 -187500 0 0 0

Table. 7.9: MPE-008
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Example 4:

AXIALSCAN, flat field (focus calibration)
# The fields can be separated by <space>, <tab> or <semicolon>

# The floating point values must use '.' as the decimal point

; Type: Offset

; FieldSize: 500000 500000

; SubFieldSize: 450000 450000

; SubFieldOffset: 0 0

; IsCircularField: False 12

12 Example continues on next page.
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; Selected layers:

; Selected magnifications:

; Magnification [] Layer [] Row [] Column [] OffsetX [bit] OffsetY [bit] OffsetZ
[bit]

0 0 0 1 0 0 0

0 0 0 2 0 0 0

0 0 0 3 0 0 0

0 0 0 4 0 0 0

0 0 0 5 0 0 0

0 0 0 6 0 0 0

0 0 0 7 0 0 0

0 0 0 8 0 0 0

0 0 0 9 0 0 0

0 0 1 0 0 0 0

0 0 1 1 0 0 0

0 0 1 2 0 0 14299

0 0 1 3 0 0 0

0 0 1 4 0 0 0

0 0 1 5 0 0 0

0 0 1 6 0 0 0

0 0 1 7 0 0 0

0 0 1 8 0 0 0

0 0 1 9 0 0 0

0 0 2 0 0 0 0

0 0 2 1 0 0 0

0 0 2 2 0 0 0

0 0 2 3 0 0 0

0 0 2 4 0 0 0

0 0 2 5 0 0 0

0 0 2 6 0 0 0

0 0 2 7 0 0 0

0 0 2 8 0 0 42897

Table. 7.10: MPE-009
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7.3.3.2 Loading a table for a single layer/magnification
Instead of loading the entire measurement table, a single data grid for a (focus) layer or
magnification can be loaded with Measurement > Load table layer.

This will only overwrite the data of the active layer of the measurement table.

The file format is the same as on page 42, Loading the complete measurement data, whereby
it must be ensured that the number of rows and columns matches the current measurement
table.

7.3.3.3 Importing a list of measurement values
If the measured points are not a uniform grid, a list of measured points defined by expected
and actual position can be imported.

Magnification and layer indices can be provided optionally. Currently only X/Y errors can be
imported, meaning actual Z must be equal to expected Z if provided.

A new measurement table must be created, taking into account the number of measurements
in the prepared list that will be imported next. The number of layers and magnifications will
be used as specified in the imported list.

For each point in the measurement table, the nearest three points to the imported points are
determined. A plane that is fitted through the measured deviation of these three points then
defines the error at that position.

The unit of measurement is [μm] and the decimal point is ‘.’.

Support format:

<expected X>, <expected Y>, <expected Z>, <actual X>, <actual Y>

NOTE: After loading or importing measurement data, it is still necessary to apply the data
and save the calibrated correction file.
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8 GRAPHICAL VISUALIZATION OF
CORRECTION FILE DATA
When loading a correction file and especially after applying measurements, you may want to
visually check the original or modified data.

Use the Graph tab to view the correction file visualization.

Fig. 8.1: MPE-ABE

NOTE: The background color of the graph can be changed from black to white (dark vs. light)
according to the user’s preference.
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The color bar defines the color of the values for the Z-axis over the graph.

The range of values depends on the selected correction unit (refer to page 75, Settings):

16 Bit 20 Bit Percent

Min. (green) -32768 -524288 -50

Max. (red) +32767 +524287 +50

Table. 8.1: MPE-010

The bar can either represent the full range of Z-axis values, or by using the “max contrast”
flag, the color range from min to max of the Z-axis will be adjusted to the min/max values of
the respective Z-layer.

More than one
Z‑axis

As soon as a correction file supports more than one Z-axis (linear axis), a selection becomes
available (below the checkbox). If the correction file supports an additional Z-axis, select
whether the displayed correction data refers to

■ Z-axis (focus),

■ SensorZ (RAYSPECTOR) or

■ Aux-axis (RAYDIME METER).

3D volumes or
Zoom‑axis

For correction files that support either 3D volumes or a Zoom‑axis, a slider is available (to the
left of the graph). It can be used to select the layer for which the corresponding correction
data should be displayed.

Navigation Navigating the graph:

■ Scroll to zoom in / out,

■ Left drag to pan.
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Type of data
visualization

Description

Correction Shows the grid of correction values

Use the “reduced” flag to change the number of grid lines from original (usually
257 x 257) to 65 x 65

Error vector 13 The error vector graph shows the measured and the expected locations.

The measured points are green and the expected points blue.

The resulting correction is shown as a red arrow.

Error cloud 13 The error cloud displays the necessary XY correction of each measured point.

The color is defined by the distance of the measured point from the center, i.e.
the color changes from green (center) to red (corner).

The scale of the plot is shown as plot size [μm] in the lower right corner.

This can be useful for deeper analysis of the nature of the errors (e.g. if the
whole field has the same offset, all points would be displayed at the same
position).

Table. 8.2: MPE-011

13 This display option is only useful as long as the deviation between the measured values and the default
values can be determined within the MULTI POINT EDITOR. Loading a correction file that has already
been edited will no longer provide this information.
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9 APPLY MEASUREMENT AND SAVE
MODIFIED CORRECTION FILE
After entering the measured values and checking them in the visualization, the values can be
applied.

After the values have been applied, a message is displayed informing you of the average and
maximum correction:

Fig. 9.1: MPE-ABF

Finally, save the modified correction: File > Save as... Save as....

TIP: It is useful to save the file with the same name as the original, but adding information
about the type of correction applied and, if necessary, the number of iterations as a suffix.

NOTES:
■ If the resulting field with the applied correction exceeds the field size (e.g. because the

field was offset), you are notified that the correction values will be clipped to fit the field
size.

■ Normally, there is no backup of the original correction file, unless you check the option in
the MPE settings (Edit > Settings...).

■ An index is appended to the filename, if the target file already exists.

■ The standalone application will upload the modified correction when saving (if still
connected to the scan controller), and the changes to the correction file will become
active. The RAYGUIDE application will also have the modified version in its configuration.
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10 GENERATING CORRECTION FILES
REPRESENTING A 3D SURFACE
When processing on a 3D surface and the vector data is not available as 3D vectors, there is
another way to adapt the focus of the laser beam to the surface. Instead of a correction file
representing a 3D volume (cuboid), the correction file, which controls the Z-axes anyway,
maps the surface shape.

To do so, the MPE offers two features.

These features require starting with a correction file that provides a 3D volume.

The result is a correction file that represents the outer shell, i.e. a single 2D layer that follows
the 3D surface.

NOTE: It is recommended to perform regular field and focus corrections on the 3D volume
before starting to create a 3D surface correction file.

10.1 Apply wrapped surface
This option allows you to create 3D correction files that not only represent a 3D surface, but
also correct the XY position of the incoming layout coordinates so that the layout wraps onto
the surface.

To calculate the correction, only certain types of surfaces are supported:

■ cylindrical surface,

■ inclined plane.
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10.1.1 Mode: Cylinder
Select: Apply wrapped surface > Mode: Cylinder

Fig. 10.1: MPE-ABG

Element Description

Cylinder axis Specify whether the cylinder axis is placed along the X- or Y-axes.

Target Select whether the cylinder represents a concave or convex curvature

Radius [mm] Enter the radius of the cylinder in [mm].

Offset z [mm] Offset of the cylinder axis relative to the zero plane of the correction file.

Offset secondary axis
[mm]

Enter the parallel offset of the cylinder axes to the selected coordinate axes.

Azimuth [°] 14 Horizontal angle of the cylinder axes relative to the selected coordinate axes.

Elevation [°] 14 Vertical angle of the cylinder axes relative to the selected coordinate axes.

Table. 10.1: MPE-012

14 Azimuth and elevation angles are limited to a maximum of ±10 degrees.
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10.1.2 Mode: Plane
Select: Apply wrapped surface > Mode: Plane

Fig. 10.2: MPE-ABH

Element Description

Offset z [mm] Offset of a “flat” plane relative to Z=0.

Azimuth [°] 15 Horizontal rotation angle of the inclined plane relative to the X-axis.

Elevation [°] 15 Tilt angle of the inclined plane in vertical perspective.

Table. 10.2: MPE-013

15 Azimuth and elevation angles are limited to a maximum of ±10 degrees.
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10.2 Apply projection
This option allows you to create almost any kind of 3D surface by importing the surface shape
from an STL file. With this option, only the Z data of the correction file is matched to the
surface, resulting in a projected image of the layout being processed. As an alternative to
importing an STL file, you can define a sphere shape by entering its radius and position.

10.2.1 Mode: Sphere
Select: Apply projection > Mode: Sphere

Fig. 10.3: MPE-ABI

Element Description

Center [mm] (X/Y/Z) Coordinate of the center of the sphere relative to the origin of working volume.

Radius [mm] Enter the radius in [mm] of the sphere.

A positive radius results in a convex sphere, while a negative radius results in a
concave sphere.

Default z [mm] Defines the Z-position for all XY-positions, that do not meet the surface of the
sphere.
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Element Description

Height bitmap […] Browse to a folder and specify a file name for a height-representing image.

Example:

This image can be e.g. loaded into the background of RAYGUIDE as an
orientation for where to place the layout object in order to hit the 3D surface.

NOTE: The darker the deeper the focus compared to Z = 0.

Table. 10.3: MPE-014
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10.2.2 Mode: STL File
Select: Apply projection > Mode “STL”

Fig. 10.4: MPE-ABJ

Element Description

[…] Select file Browse to the desired STL file and load it.

Offset[mm] Define the offset from the origin of the STL File to the origin of the working
volume given by the correction file.

Scale [%] Scaling of the STL file dimensions in percent (in X-, Y-, Z‑dimension)

By default, the dimensions are locked for the same aspect ratio.

Unlock if necessary.

Rotation [°] Enter an angle to rotate the 3D surface relative to the axis of the correction file

Default z]mm] Defines the Z-position for all XY positions, that do not meet the STL surface.
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Element Description

Height bitmap […] Browse to a folder and specify a file name for a height-representing image.

Example:

This image can be e.g. loaded into the background of RAYGUIDE as an
orientation, where to place the layout object in order to hit the 3D surface.

NOTE: The darker the deeper the focus compared to Z = 0.

Infos

Min.[mm] (X/Y/Z) Shows the minimum position of the surface in each axis direction

Center [mm] Use the [Reset] button to center the surface inside the volume.

This sets the STL origin to the working volume origin.

The values show the actual offset between the two origins.

Max.[mm] (X/Y/Z) Shows the maximum position of the surface in each axes direction.

Size [mm] (X/Y/Z) Surface size along the three axis dimensions, including scaling.

Table. 10.4: MPE-015

TIP: To avoid cropping the imported surface, make sure all positions are inside the 3D volume.

Next to the value field, a preview shows the actual position of the surface relative to the
working volume. Use the two sliders to adjust the point of view.
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11 CORRECTION FILE HEADER
The *.fc3 correction file contains a lot of additional information in what is called the
"header". This information includes the metadata, too.

Go to Edit > Change header

The only editable value here is the Z-offset, which can be used to set the reference plane
(Z = 0) other than the default defined by RAYLASE.

The Info field can be used to enter custom information.

NOTE: The header data is used by the control card, while the metadata is just additional
information that specifies more detailed information about the optical setup that the
correction file applies to.

Example: AM-MODULE header

Fig. 11.1: MPE-ABK

Example: Header with additional metadata

Fig. 11.2: MPE-ABL
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12 POSITION DEPENDENT POWER
CORRECTION FILE
The MULTI POINT EDITOR software can also be used to create power correction files. These
files are uploaded to the control card to adjust the laser power based on the field position.

A common use case would be to compensate for the variation in power density caused by
variation in spot size due to deflection angle.

To generate a new power correction file, select File > Generate power correction.

NOTE: The power correction is not part of the field correction. Instead, this method creates a
special correction file named *.pc3.

In the following dialog, you have to define the number of grid points and layers (in case of a
3D workspace) as well as the field size (according to the used field correction file).

Fig. 12.1: MPE-ABM

In addition, the "No power outside sub field" flag can be checked to force power scaling to
zero outside the sub field. This type of power correction is used, for example, to avoid laser
power emission when the scanner targets a position outside the defined sub field (see page
19, Optional field range limitation for calibration (sub field).

NOTE: To use the flag, the sub field must first be defined (in a field size that matches the field
size of the power correction, or a field correction file with a sub field definition must have
been loaded before (refer to page 19, Optional field range limitation for calibration (sub
field)).
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When you click [OK], the basis for the power correction is created, resulting in a scale factor
= 1 for the entire field used.

NOTE: Although you are presented with a measurement table, this 3 x 3 table is not ready for
your input.

Next, go to the Measurement > New table menu to create the table for entering the
scaling factors for the power correction required.

Fig. 12.2: MPE-ABN

The grid with the channel0 tab is used to control the laser power on the main power control
card. Channel1 is optional if the laser has defined a secondary power target (usually Dac1).
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The range of values to enter can be from factor 0 to factor 4. You can also enter decimal
values, the display will just round them to 2 digits.

Fig. 12.3: MPE-ABO

On the Correction tab, you will notice that the scaling factors are again distributed over the
array of grid points. Since the number of grid points is likely to be larger than the number of
points in the measurement table, the values are interpolated accordingly.
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Again, there are two subtabs for channel0 and channel1:

Fig. 12.4: MPE-ABP

As an alternative to entering the values manually, the values can also be loaded from a file.

To load power correction values, the "Type" must be "Scale".

Example:
# Multipoint FieldCorrection File

# The data contained herein describes the scale applied to the correction values.

# Scale of 1 equals original value

# Each line lists one data point consisting of

# [Magnification/Layer/]Row/Column: the position where the data point is expected
expressed as [magnification/layer/]row/column

# ScaleX/Y/Z: multiplier

# Empty lines and lines that begin with '#' are ignored

# The fields can be separated by <space>, <tab> or <semicolon>

# The floating point values must use '.' as the decimal point 16

16 Example continues on next page.
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; Type: Scale

; FieldSize: 100000 100000

; Selected layers:

; Selected magnifications:

; Magnification [] Layer [] Row [] Column [] ScaleX [] ScaleY [] ScaleZ []

0 0 0 0 2.5 1 1 1 1

0 0 0 1 2.5 1 1 1 1

0 0 0 2 2.5 1 1 1 1

0 0 0 3 2.5 1 1 1 1

0 0 0 4 2.5 1 1 1 1

0 0 0 5 2.5 1 1 1 1

0 0 0 6 2.5 1 1 1 1

0 0 0 7 2.5 1 1 1 1

0 0 0 8 2.5 1 1 1 1

0 0 0 9 2.5 1 1 1 1

0 0 0 10 2.5 1 1 1 1

0 0 1 0 2.5 1 1 1 1

0 0 1 1 2.1 1 1 1 1

0 0 1 2 2.1 1 1 1 1

0 0 1 3 2.1 1 1 1 1

0 0 1 4 2.1 1 1 1 1

0 0 1 5 2.1 1 1 1 1

0 0 1 6 2.1 1 1 1 1

0 0 1 7 2.1 1 1 1 1

0 0 1 8 2.1 1 1 1 1

0 0 1 9 2.1 1 1 1 1

0 0 1 10 2.5 1 1 1 1

0 0 2 0 2.5 1 1 1 1

0 0 2 1 2.1 1 1 1 1

0 0 2 2 1.75 1 1 1 1

0 0 2 3 1.75 1 1 1 1

Table. 12.1: MPE-016
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After confirming the entered values with the [Apply] button, similar to the field correction,
the entered values can be visualized in a kind of heat map. Clicking the [Show graph]
button switches directly to the Graph tab to view the power scaling distributed over the scan
field.

Example: (corresponds to the values as shown in the previous table)

Fig. 12.5: MPE-ABQ

To switch the graph display from channel0 to channel1, use the drop-down menu below the
color bar.

Once the power correction is done, you can save the file: File > Save / Save as...

Upload the file to the control card, either directly through API commands or through the
RAYGUIDE Laser configuration. The appropriate file type is *.pc3.
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13 DETERMINATION OF MAXIMUM
PROCESS SPEEDS
On the data sheets of the deflection units, the maximum processing speeds are usually given
in [rad/s] and in [mm/s] for the linearly moving Z-axis. These are the speeds at which the
lenses move, not, for example, how fast the focus can be moved in the field along the Z‑axis.

When working with an AM-MODULE, the magnification speed must also be specified as an
application parameter. The speed is given in [1/s], which is the number of magnification
change per time.

Information stored in the correction file can be used to convert data sheet values to field
domain units. Therefore, the MPE provides a function to analyze and calculate the processing
speed.

Go to Correction > Analyze.

The dialog shown below opens and provides the following information and functions:

■ Left: Analysis of 3D correction file (example)
■ Right: Analysis of an AM-MODULE correction file (example).

Fig. 13.1: MPE-ABS
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13.1 Control values
The table shows the maximum control values used in the correction file per axis depending on
the selected units.

You can select the following units:

■ 16-bit resolution (valid for XY2-100 protocol),

■ 20-bit resolution (valid for SL2-100 or RL3-100 protocol),

■ Percent (of axis movement range),

■ Percent (margin).

13.2 Speed limits
First, you need to enter the speed limits in [rad/s] as specified in the corresponding deflection
unit datasheets.

NOTE: Please be careful to check the value, as it may depend on the aperture size, mirror
substrate, and so on.

The Z-axis speed is specified in [mm/s]. The default maximum speed for all common Z-axes is
900 mm/s. If necessary, you can enter a different speed value.

Table explanation

XY Plane These values are valid when the scanning trajectory is limited to a XY plane.

Z direction This value represents the case when the spot moves vertically along the
Z direction only.

All axes This value includes the movement of all axes involved.

For example, if the deflection unit is a prefocusing unit, the usually less dynamic
Z‑axis is also considered to maintain the focus position.

XY axes This value considers only the movement of the XY mirrors, excluding any
possible Z-axis.

Magnification Value for the maximum possible magnification speed

Table. 13.1: MPE-024
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14 COMMAND LINE

14.1 Correction file generation
A command line interface is available to programmatically generate field correction files
(*.fc3) or power correction files (*.pc3) using script commands.

The generated file will be saved in the same path as the input file and will have the same
name, regardless of the extension. If a file with the same name already exists, it will be
overwritten without asking.

If the correction values exceed the field, they are automatically clipped.

14.1.1 Generation of *.fc3 files
For *.fc3 generation the following arguments are expected in this order:

Argument Default value

fc3 -

txz filename (with path) -

optional config file name XYMaxGalvoAngles = 22.5,

MaxLensTravel = 11.

In case of a focusshifter, MaxLensTravel is
calculated as 1048575 / taxiscalfactor.

optional rows 257

optional columns 257

optional layers 17

Table. 14.1: MPE-027

14.1.2 Generation of *.pc3 files
For *.pc3 generation the following arguments are expected in this order:

Argument Default value

pc3 -

txz filename (with path) -

optional rows 257

optional columns 257

optional layers 17

Table. 14.2: MPE-028
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14.2 Apply measurement table
The measurement table can be applied to a correction file with or without a sub field.

14.2.1 Without sub field
The following arguments are expected in this order:

Argument Explanation

applyError -

correction file name *.fc3 or *.pc3

measurement table file name For file format, see page 41, Loading
measurement values from a file.

optional new correction file name The original file will be overwritten if the
new name is not set.

Example including new file name:

MultiPointEditor.exe applyError
“correction.fc3” “measurements.mtf”
“newFileName.fc3”

Quotes are only necessary if the path
contains whitespace.

Table. 14.3: MPE-029

14.2.2 With sub field
The following arguments are expected in this order:

Argument Explanation

applyErrorSubfield -

correction file name *.fc3 or *.pc3

measurement table file name For file format, see page 41, Loading
measurement values from a file.

sub field size X [μm] -

sub field size Y [μm] -

sub field offset X [μm] -

sub field offset Y [μm] -

optional new correction file name The original file will be overwritten if the
new name is not specified.

Table. 14.4: MPE-030
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14.3 Apply bit error
A bit error table can be applied to the correction file. The values are interpolated to the
dimensions of the correction file and then added to the correction values.

Expected format:

; Layer Row Column OffsetX [bit] OffsetY [bit] OffsetZ [bit] Offset4 [bit] Offset5
[bit]

0 0 0 0 0 0 0 297.886

0 0 0 0 0 0 0 500

Table. 14.5: MPE-017

The following arguments are expected in this order:

Argument Explanation

applybiterror -

correction file name *.fc3 or *.pc3

bit error table file name -

optional new correction file name If the new name is not specified, the original
file will be overwritten.

Table. 14.6: MPE-031

14.4 Logging
A log file is created at

%programdata%\RAYLASE\Multi Point Editor\Logs\MultiPointEditorConsole.log

It contains the parameters with which the program was called and any messages.
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15 LOG DATA
If MPE is started directly from the RAYGUIDE application, the logging is part of the standard
RAYGUIDE logs, see the RAYGUIDE manual.

When the MPE is used as a standalone application, it creates log files in the following path:

C:\ProgramData\RAYLASE\Multi Point Editor\Logs\

Two log files are created:

■ Application log file: MultiPointEditor.log
■ SP-ICE-3 log file: SPICE3Mpe.log

It tracks all commands sent to the SP-ICE-3 scan controller.

To navigate to the log files, go to Help > Log

If requested by RAYLASE support, please send these files for troubleshooting to
support@raylase.de.



16 SETTINGS

© 2025 RAYLASE GmbH 75MN_MULTI POINT EDITOR [V2.1]

16 SETTINGS
There are two things to define in the Settings... dialog:

■ If and where the backup file of the original correction files is stored.

■ Correction display unit: 20 bit / 16 bit / Percent.

To open the dialog, select Edit > Settings...

Fig. 16.1: MPE-ABR
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17 EXPLANATION OF CORRECTION FILE
NAMING
Correction file naming is a continuous improvement process, so you may find it a bit
confusing.

The following example should help you to extract the important information from the
naming.

Customer specivic correction files may be named differently. The examples below do not
cover all possible abbreviations that may be used.

17.1 Correction files for 2-axis deflection units

Correction file name Explanation

4401-499-000-26_SS-IV-15_LR-20,0-003.fc3

4401-499-000-26_

SS-IV-15_

LR-20,0-003.fc3

■ Vendor ID F-Theta lens_

■ SS-IV head model - with 15mm mirror aperture_

■ Lens ring spec

2407_SS-II-20_4401-508-000-26.fc3

2407_

SS-II-20_

4401-508-000-26.fc3

■ RAYLASE list ID_

■ SS-II to SS-V head model - with 20mm mirror aperture_

■ Vendor ID F-Theta lens

Table. 17.1: MPE-018
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17.2 Correction files for AXIALSCAN, AS FIBER 
(with or without RAYSPECTOR, RAYDIME
METER)

Correction file name Explanation

2D_AS-F-30-Y_250.0_WD257_off2_PW3+4_SZ2.fc3

2D_

AS-F-30-Y_

250.0_

WD257_

off2_

PW3+4_

SZ2.fc3

■ Flat field_

■ AS FIBER-30mm mirror aperture-YAG wavelength_

■ 250mm field size_

■ 257mm working distance_

■ 2mm Z-Lens offset_

■ two protective windows_

■ Support of SensorZ-axis

3D_AS-50-Y_300-1000_WV3917.fc3

3D_

AS-50-Y_

300-1000_

WV3917.fc3

■ 3D volume_

■ AXIALSCAN-50mm mirror aperture-YAG wavelength_

■ 300mm-1000mm field size_

■ 3917mm Working Volume

3D_AS-F-30-Y_300_WD318_off2_WV47_PW3+4.fc3

3D_

AS-F-30-Y_

300_

WD318_

off2_

WV47_

PW3+4.fc3

■ 3D volume_

■ AS FIBER-30mm mirror aperture-YAG wavelength_

■ 300mm field size_

■ 318mm working distance_

■ 2mm Z-Lens offset_

■ 47mm working volume_

■ two protective windows
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Correction file name Explanation

3D_AS-F-30-633_400_WD447_off5.5_WV10_PW3_SZ2_SZ3.fc3

3D_

AS-F-30-633_

400_

WD447_

off5.5_

WV10_

PW3_

SZ2_

SZ3.fc3

■ 3D volume_

■ AS FIBER-30mm mirror aperture-633nm special wavelength_

■ 400mm field size_

■ 447mm working distance_

■ 5,5mm Z-Lens offset_

■ 10mm working volume_

■ one protective window_

■ Support of SensorZ-axis_

■ Support of Aux-axis used in RAYDIME METER

2D+M_AS-F-50_370_WD378_off2_def4.0x_NA75_Msq1.1.fc3

2D+M_

AS-F-50_

370_

WD378_

off2_

def4.0x_

NA75_

Msq1.1.fc3

■ Flat field plus magnification_

■ AS FIBER-50mm mirror aperture_

■ 370mm field size_

■ 378mm working distance_

■ 2mm Z-Lens Offset_

■ 4x Defocusing_

■ 75mm NA of AS FIBER_

■ M² of 1.1

Table. 17.2: MPE-019
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17.3 Correction files for FOCUSSHIFTER

Correction file name Explanation

3D_LT-FC3-05-[Y]_4401-301-000-21_MS-14.fc3

3D_

LT-FC3-05-[Y]_

4401-301-000-21_

MS-14.fc3

■ 3D volume_

■ Linear Translator_

■ FOCUSSHIFTER Compact Size - 3-fold internal beam expansion - 5mm
input aperture-YAG wavelength_

■ Vendor ID F-Theta lens_

■ MINISCAN - with 14mm mirror aperture

2690_FS-RD-14-Y_017700-025-26.fc3

2690_

FS-RD-14-Y_

017700-025-26.fc3

■ MPE List ID_

■ FOCUSSHIFTER-RAYVOLUTION DRIVE - 14mm mirror aperture – YAG
wavelength_

■ Vendor ID F-Theta lens

2364_FS-L2-05-TY_SS-II-15_4401-481-000-21.gcd

2364_

FS-L2-05-TY_

SS-II-15_

4401-481-000-21.gcd

■ MPE List ID_

■ FOCUSSHIFTER-2-fold beam expansion-5mm input aperture - Triple YAG
wavelength_

■ SS-II to SS-V head models-15mm mirror aperture_

■ Vendor ID F-Theta lens

Table. 17.3: MPE-020
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17.4 Corrections Files for AM MODULE

Correction file name Explanation

2D_AM-30RD-F085_0500_WD566_off0,5_Z2,2.fc3

2D_

AM-30RD-F085_

0500_

WD566_

off0,5_

Z2,2.fc3

■ Flat field_

■ AM-MODULE-30mm mirror aperture - 85mm focal length collimator_

■ 500mm field size_

■ 566mm working distance_

■ 0,5mm Z-Lens offset_

■ max. magnification factor = 2.2

Table. 17.4: MPE-021
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